přejít na obsah přejít na navigaci

Linux E X P R E S, jQuery 2.0 nebude podporovat starší verze IE

Control

jQuery 2.0 nebude podporovat starší verze IE

Verze 2.0 javascriptové knihovny jQuery nebude podporovat Internet Explorer ve starších verzích než 9.


reklama

Javascriptová knihovna jQuery se stala velmi populární – díky snadnosti použití, licencování (licence MIT a GPL) a v neposlední řadě také přenositelnosti mezi prohlížeči. Poslední důvod ale podle plánů vývojářů již do určité míry přestane platit. Verze 2.0 totiž již nebude podporovat starší verze prohlížeče Internet Explorer, konkrétně 6, 7 a 8. Cílem je vyčistit a zrychlit kód, který kvůli podpoře těchto prohlížečů obsahuje nemálo workaroundů.

Není však třeba mít obavy ohledně odstřižení nezanedbatelného množství uživatelů, kteří z různých důvodů zastaralé verze používají. Autoři jsou si situace vědomi a tak plánují současně s verzí 2.0 vydat i verzi 1.9, která bude mít API kompatibilní s verzí 2.0, ale staré verze IE podporovat bude. Obě verze přijdou až v příštím roce, mnohem dříve by se však měla objevit verze 1.8 (nyní ve fázi beta) obsahující zásadně přepracovaný a vylepšený selektorový engine.

Nahoru

Přidat téma diskuse

Nejsou podporovány žádné značky, komentáře jsou jen čistě textové. Více o diskuzích a pravidlech najdete v nápovědě.
Diskuzi můžete sledovat pomocí RSS kanálu rss



 
 

Top články z OpenOffice.cz

Lukáš Jelínek

Lukáš Jelínek

Dlouholetý člen autorského týmu LinuxEXPRESu a OpenOffice.cz. Vystudoval FEL ČVUT v oboru Výpočetní technika. Žije v Kutné Hoře a podniká v oblasti informačních technologií. Ve volném čase rád fotografuje, natáčí a stříhá video, občas se věnuje powerkitingu a na prahu čtyřicítky začal hrát tenis.


  • Distribuce: Debian, Linux Mint
  • Grafické prostředí: KDE

| proč linux | blog


Tiskárna Brno