přejít na obsah přejít na navigaci

Linux E X P R E S, Chrome 39 vyžaduje nové verze jádra

EDU Trainings IT školení

Chrome 39 vyžaduje nové verze jádra

Chrome

Webový prohlížeč Chrome/Chromium od verze 39 vyžaduje linuxové jádro ve verzi 3.17 nebo novější (kvůli podpoře SECCOMP_FILTER_FLAG_TSYN). Se staršími verzemi nelze využívat žádná rozšíření prohlížeče.


Webový prohlížeč Google Chrome (a jeho svobodná varianta Chromium) počínaje verzí 39 vyžaduje, aby linuxové jádro podporovalo příznak SECCOMP_FILTER_FLAG_TSYN. Ten určuje, zda lze v „bezpečném režimu“ (secure computing) synchronizovat běžící vlákna při instalaci nového filtru pro secure computing. K dispozici je však až u jádra verze 3.17 a novějších.

Vzhledem k tomu, že linuxové distribuce často obsahují starší verze, řeší to jejich tvůrci patchováním jádra. To je třeba případ distribuce Ubuntu 14.10. Jiné distribuce – například Debian – však jádro upravené nemají a Chrome/Chromium v jejich aktuální verzi tedy plnohodnotně fungovat nebude.

Nahoru

Příspěvky

Chrome 39 vyžaduje nové verze jádra
xhc 8. 03. 2015, 19:12:15
Odpovědět  Odkaz 
"Se staršími verzemi nelze využívat žádná rozšíření prohlížeče."

nerozumiem tomu, mám wheezy, chrome 41 a 3 chrome extensions, ktoré fungujú
Lukáš Jelínek Re: Chrome 39 vyžaduje nové verze jádra
Lukáš Jelínek 8. 03. 2015, 19:41:43
Odpovědět  Odkaz 
Nevím, tady je téma v mailové konferenci Debianu, které se tím zabývá (a nasvědčuje tomu, že ten problém v Debianu skutečně existuje, a to i ve verzi Jessie): https://lists.debian.org/debian-kernel/2015/03/msg00133.html
Re: Chrome 39 vyžaduje nové verze jádra
jan 9. 03. 2015, 09:47:14
Odpovědět  Odkaz 
Nebude se to týkat pouze rozšíření, které využívají PNaCl/PPAPI? (jen dohad)
Chrome 39 vyžaduje nové verze jádra
kuba77 8. 03. 2015, 21:23:12
Odpovědět  Odkaz 
Tak to se mě s Arch Linuxem netýká :-D Linux 3.18.6 a Chromium 41.
Chrome 39 vyžaduje nové verze jádra
pakrik 9. 03. 2015, 15:09:50
Odpovědět  Odkaz 
Podobne fedora 21 , 3.18.7-200.fc21.x86_64
Re: Chrome 39 vyžaduje nové verze jádra
Jirka 12. 03. 2015, 12:39:16
Odpovědět  Odkaz 
Hmmm...tak v openSUSE 13.1 mám jádro Linux 3.11.10-25-default i686 a Chromium verze 40.0.2214.111. Prostě tak, jak to je v repozitářích a jak se to automaticky aktualizuje, žádné ruční zásahy jsem v tomto smyslu nedělal.

Vše funguje jak má, i když - pravda - doplňky v Chromiu nějak neřeším...

Přidat názor

Nejsou podporovány žádné značky, komentáře jsou jen čistě textové. Více o diskuzích a pravidlech najdete v nápovědě.
Diskuzi můžete sledovat pomocí RSS kanálu rss



 
 

Top články z OpenOffice.cz

Lukáš Jelínek

Lukáš Jelínek

Dlouholetý člen autorského týmu LinuxEXPRESu a OpenOffice.cz. Vystudoval FEL ČVUT v oboru Výpočetní technika. Žije v Kutné Hoře, podniká v oblasti IT a zároveň pracuje v týmu projektu Turris. Ve volném čase rád fotografuje, natáčí a stříhá video, občas se věnuje powerkitingu a na prahu čtyřicítky začal hrát tenis.


  • Distribuce: Debian, Kubuntu, Linux Mint
  • Grafické prostředí: KDE

| proč linux | blog



Public Relations

Domény a nepřeberné množství internetových adres s možností jejich zneužití

dnnsecNepropásněte sérii webinářů zaměřených na aktuální bezpečnostní trendy a jednotnou správu zabezpečení vaše IT – každé pondělí a zdarma.
S doménami přijde do kontaktu naprosto každý uživatel internetu, ačkoliv si to asi neuvědomuje. Už jenom samotné hledání na internetu je spojené s doménami, o nakupování v internetových obchodech ani nemluvě. Věděli jste však, že domény mohou být poměrně jednoduše napadeny?

Pokračování ...


EDU Trainings

Redakční blog

Pavel Fric

Pavel Fric, 21. srpen

Sayonara Player 1.5.1

Přehrávač, jak má být. Poslední dobou vývoj šlape


Pavel Fric

Pavel Fric, 26. leden

MuseScore 3

První aktualizace třetí řady notačního editoru MuseScore


Redakce

Redakce, 21. prosinec

Pište pro LinuxEXPRES

Baví vás Linux? Pište o něm, není to nic těžkého. LinuxEXPRES hledá nové autory.


Všechny blogy »

SOPHOS - hacking webinar 1