<!DOCTYPE html>
<html itemscope itemtype="http://schema.org/Article" lang="cs">
<head>
<script type="text/javascript">


  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-152437-48', 'linuxexpres.cz',{siteSpeedSampleRate: 10});
   
      ga('set', 'dimension1', 'Eduard Boldižár'); ga('set', 'dimension2', '0'); ga('set', 'dimension3', ''); //


ga('set', 'dimension5', '1');         

 
  </script>
<meta charset="utf-8" />  
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<meta name="robots" content="index,follow" />
<meta name="keywords" content="C++, cyklus while" />
<meta name="description" content=" Druhý diel sa zapodieva cyklom do&nbsp;while. Dočítate sa o&nbsp;funkcionalite spomenutého cyklu a&nbsp;naučíte sa s&nbsp;ním pracovať na&nbsp;základe ukážkových príkladov. " />
<meta name="rating" content="general" />
<meta name="author" content="CCB, spol. s r.o." /> 
<meta name="generator" content="Marwel" />
<meta name="alexaVerifyID" content="gQYss0M3qZ-_t097Op16dL_fXiQ" />
<title>Programovanie v jazyku C++: Cyklus while (2) - Linux E X P R E S</title>
<link href="https://www.linuxexpres.cz/favicon.ico" rel="SHORTCUT ICON" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/css/main.css?2014131450"     type="text/css" media="screen, projection" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/css/inline.css?0206101144"     type="text/css" media="screen, projection" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/css/print.css"    type="text/css" media="print" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/css/handheld.css" type="text/css" media="handheld" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/styles/shCoreDefault.css" type="text/css" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/styles/shThemeDefault.css" type="text/css" />
<link rel="stylesheet" href="https://www.linuxexpres.cz/themes/le/js/calendar/calendar-blue.css" type="text/css" />
<link rel="alternate" title="RSS - články" href="https://www.linuxexpres.cz/rss/clanky" type="application/rss+xml" />
<link rel="alternate" title="RSS - novinky" href="https://www.linuxexpres.cz/rss/novinky" type="application/rss+xml" />
<link rel="alternate" title="RSS - blog"   href="https://www.linuxexpres.cz/rss/blog" type="application/rss+xml" />
<link rel="alternate" title="RSS - komentáře" href="https://www.linuxexpres.cz/rss/diskuze" type="application/rss+xml" />
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/scriptaculous/lib/prototype.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/scriptaculous/scriptaculous.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/qcm/qcm.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/global.js?0407111356"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/flashcontrol/swfobject.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/scripts/shCore.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/scripts/shBrushBash.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/scripts/shBrushAS3.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/scripts/shBrushPhp.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/scripts/shBrushSql.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/syntaxhighlighter/scripts/shBrushXml.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/calendar/calendar.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/calendar/calendar-setup.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/themes/le/js/calendar/lang/calendar-cs.js"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<script type="text/javascript">
    <!--
    //--></script><script type="text/javascript" src="https://www.linuxexpres.cz/modules/marwel/js/behavior.js"></script>
<script type="text/javascript" src="https://www.linuxexpres.cz/modules/marwel/js/dots.js"></script>
<script type="text/javascript"><!--
  Behaviour.addLoadEvent(function(){replaceDots();});
--></script>
<script type="text/javascript"><!--
    //-->
    Cookie.init({name: 'jscoockies'}, {});
    var ads = [];
    </script>
<meta itemprop="name" content="Programovanie v jazyku C++: Cyklus while (2)" />
<meta itemprop="description" content=" Druhý diel sa zapodieva cyklom do&nbsp;while. Dočítate sa o&nbsp;funkcionalite spomenutého cyklu a&nbsp;naučíte sa s&nbsp;ním pracovať na&nbsp;základe ukážkových príkladov. " />
<meta itemprop="image" content="https://www.linuxexpres.cz/uploads/perexy/cplusplus.png">
</head>
<body id="www-linuxexpres-cz">
<div class="leaderbord">
</div>     <div class="mainbody">
<div id="all">
<div id="wrapper">
<header>
<a href="#content" class="hidden-nav" title="" accesskey="s">přejít na obsah</a>
<a href="#menu" class="hidden-nav1" title="Přejít na navigaci" >přejít na navigaci</a>
<h1 id="logo"><a href="https://www.linuxexpres.cz"><span>Linux E X P R E S, Programovanie v jazyku C++: Cyklus while (2)</span></a></h1>
<div id="row-site-navigation">
<nav>
<ul class="level1">
<li class=" first ">
<a href="https://www.linuxexpres.cz/zpravodajstvi" title="Zpravodajství" class="zpravodajstvi">Zpravodajství</a>
</li>
<li class=" e menu-active-parent submenu">
<a href="https://www.linuxexpres.cz/software" title="Software" class="software">Software</a>
<ul class="level2">
<li class=" o ">
<a href="https://www.linuxexpres.cz/software/kde4-1" title="Pro KDE" class="software/kde4-1">Pro KDE</a>
</li>
<li class=" e ">
<a href="https://www.linuxexpres.cz/software/gnome-1" title="Pro GNOME" class="software/gnome-1">Pro GNOME</a>
</li>
<li class=" o ">
<a href="https://www.linuxexpres.cz/software/gtk-xfce" title="GTK, Xfce" class="software/gtk-xfce">GTK, Xfce</a>
</li>
<li class=" e ">
<a href="https://www.linuxexpres.cz/software/qt" title="Qt" class="software/qt">Qt</a>
</li>
<li class=" o ">
<a href="https://www.linuxexpres.cz/software/java" title="Java" class="software/java">Java</a>
</li>
<li class=" e ">
<a href="https://www.linuxexpres.cz/software/textove-prostredi" title="Textové prostředí" class="software/textove-prostredi">Textové prostředí</a>
</li>
<li class=" o ">
<a href="https://www.linuxexpres.cz/software/jine-systemy" title="Jiné systémy" class="software/jine-systemy">Jiné systémy</a>
</li>
</ul>
</li>
<li class=" o ">
<a href="https://www.linuxexpres.cz/hardware" title="Hardware" class="hardware">Hardware</a>
</li>
<li class=" e ">
<a href="https://www.linuxexpres.cz/analyza" title="Analýzy" class="analyza">Analýzy</a>
</li>
<li class=" o ">
<a href="https://www.linuxexpres.cz/temata" title="Témata" class="temata">Témata</a>
</li>
<li class=" e ">
<a href="https://www.linuxexpres.cz/praxe" title="Praxe" class="praxe">Praxe</a>
</li>
<li class=" o ">
<a href="https://www.linuxexpres.cz/kancelar" title="Kancelář" class="kancelar">Kancelář</a>
</li>
<li class=" e ">
<a href="https://www.linuxexpres.cz/hry" title="Hry" class="hry">Hry</a>
</li>
<li class=" o ">
<a href="http://www.libit.cz" title="Školení Linux" class="obchod-liberix-cz">Školení Linux</a>
</li>
</ul>
</nav>
</div>
<div id="reklama-top">
<!-- id=4018 --><a href="https://i.ccb.cz/inc/redirect.php?id=4018&amp;kam=https%3A%2F%2Fwww.systemonline.cz%2Fsoutez%2Fsoutez-o-stylovy-prenosny-monitor-s-usb-napajenim.htm" rel="nofollow" target='_blank'><img src='https://i.ccb.cz/img/13c6df47a9440be0aa4fa906822a2760.gif' alt='Soutěž - monitor AOC' border='0' /></a>
</div>
<div id="user-block">
<div>
<span>
Anonym:
</span>
<a href="https://www.linuxexpres.cz/user.php">přihlásit</a> | <a href="https://www.linuxexpres.cz/register.php">registrovat</a>
</div>
</div>
</header>
<div class="wrappercon">
<div id="main">
<div class="middle">
<div class="column-in" id="content">
<div id="main-content-center">
<div class="breadcrumb">
<a href="https://www.linuxexpres.cz" title="Zobrazit titulní stránku">Home</a>
&raquo;
<a href="https://www.linuxexpres.cz/clanky" title="Zpět na článek: Články">Články</a>
&raquo;
<a href="https://www.linuxexpres.cz/software" title="Zpět na článek: Software">Software</a>
&raquo;
<a href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-uvod-a-historia-1" title="Zpět na článek: Programovanie  v jazyku C++: Úvod a história (1)">Programovanie  v jazyku C++: Úvod a história (1)</a>
&raquo;
<span title="Aktuální článek:"><em>Programovanie v jazyku C++: Cyklus while (2)</em></span>
</div>
<article>
<!--Sklik-kontext-start -->
<!-- google_ad_section_start -->
<div id="article" class="article ">
<div id="fb-root"></div>
<script type="text/javascript">
    window.fbAsyncInit = function() {
      FB.init({status: true, cookie: true, xfbml: true});
      FB.Event.subscribe('edge.create', function(targetUrl) {
 ga('send', 'social', {socialNetwork: 'facebook', socialAction: 'like', targetUrl});
           });
      FB.Event.subscribe('edge.remove', function(targetUrl) {
       ga('send', 'social', {socialNetwork: 'facebook', socialAction: 'unlike', targetUrl});
      });
      FB.Event.subscribe('message.send', function(targetUrl) {
      ga('send', 'social', {socialNetwork: 'facebook', socialAction: 'send', targetUrl});
      });
    };
    (function() {
      var e = document.createElement('script'); e.async = true;
      e.src = document.location.protocol +
        '//connect.facebook.net/cs_CZ/all.js';
      document.getElementById('fb-root').appendChild(e);
    }());
    /* <![CDATA[ */
    (function() {
      var s = document.createElement('script'), t = document.getElementsByTagName('script')[0];
      s.type = 'text/javascript';
      s.async = true;
      s.src = '//api.flattr.com/js/0.6/load.js?mode=auto';
      t.parentNode.insertBefore(s, t);
    })();
    /* ]]> */
  </script>
<div class="article_chapter">
<div class="top">
<a href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-cyklus-while-1" title="Programovanie v jazyku C++: Cyklus while (1)" class="prev">Předchozí kapitola</a>
<a href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-uvod-a-historia-1" title="Programovanie  v jazyku C++: Úvod a história (1)" class="center" >Zpět na obsah</a>
</div>
</div>
<h2>Programovanie v jazyku C++: Cyklus while (2)</h2>
<div class="article-perex">
<figure><img src="https://www.linuxexpres.cz/uploads/perexy/cplusplus.png" alt="cplusplus.png" class="perex_image"/></figure>
<p class="entry-summary">Druhý diel sa zapodieva cyklom do&nbsp;while. Dočítate sa o&nbsp;funkcionalite spomenutého cyklu a&nbsp;naučíte sa s&nbsp;ním pracovať na&nbsp;základe ukážkových príkladov.</p>
</div>
<hr class="cleaner" />
<p class="article-info top-info">
Pátek,&nbsp;10.&nbsp;únor&nbsp;2017
|       <span class="vcard">Autor <a class="fn url" href="https://www.linuxexpres.cz/userinfo.php?uid=5967">Eduard Boldižár</a></span>
| <span class="art-rate"  title="Hodnocení článku: 1,00">známka <strong>1,00</strong></span>
<br class="noprint" />
</p>
<div class="art-banner">
<!-- le_article_top_468x60 -->
<div align="center"><!-- id=2845 --><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LE-468x60 -->
<ins class="adsbygoogle"
style="display:inline-block;width:468px;height:60px"
data-ad-client="ca-pub-2826757030954706"
data-ad-slot="5121894444"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<script type="text/javascript" src="//c.imedia.cz/js/script.js"></script>
<p class="reklama"><a href="http://www.linuxexpres.cz/o-webu/reklama" title="inzerujte na LinuxEXPRESu - reklamní plocha LE08">reklama</a></p>
</div>
<div class="article-content">
<h3>Do-while cyklus﻿</h3>
<p>Cyklus <em>do-while </em>má trochu odlišnú funkcionalitu ako cyklus <em>while</em>. Najprv si ukážeme deklaráciu: ﻿</p>
<pre>&nbsp;do

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; telo cyklu

while(testovacia podmienka);﻿</pre>
<p>Princípom cyklu <em>do while</em> je ten, že bez ohľadu na&nbsp;podmienku sa cyklus aspoň raz vykoná. Práve slovo <em>do </em>znamená v&nbsp;angličtine robiť. Začne sa vykonávať telo cyklu a&nbsp;až na&nbsp;konci narazí na&nbsp;podmienku, ktorú už verne poznáte. Príklad nám ukáže, ako to funguje. ﻿</p>
<p><strong>1. príklad: </strong>Cyklus do&nbsp;while﻿</p>
<pre>#include &lt;iostream&gt;&nbsp;&nbsp;&nbsp; // hlavičkový súbor
 using namespace std;&nbsp;&nbsp; // priestor mien
 
 int main()&nbsp;&nbsp; // hlavná funkcia
 {
 &nbsp; int cislo = 0;&nbsp;&nbsp; // deklarácia premennej
 
 &nbsp; do&nbsp;{&nbsp; // začiatok cyklu do&nbsp;while
 &nbsp;&nbsp;&nbsp; cout &lt;&lt; "Ja som cislo: " &lt;&lt; cislo &lt;&lt; "\n";&nbsp;&nbsp; // výpis na&nbsp;obrazovku
 &nbsp;&nbsp;&nbsp; cislo++;&nbsp;&nbsp; // inkrementácia
 &nbsp; } while (cislo &lt; 5);&nbsp;&nbsp; // podmienka cyklu do&nbsp;while
 
 &nbsp; return 0;&nbsp;&nbsp; // koniec programu
 }﻿</pre>
<p>Výsledok programu: ﻿</p>
<pre> Ja som cislo: 0
 Ja som cislo: 1
 Ja som cislo: 2
 Ja som cislo: 3
 Ja som cislo: 4﻿</pre>
<p><em>Rozbor programu: </em>﻿</p>
<p>Po inicializácii premennej začne cyklus <em>do while</em>. Prvé vykonanie cyklu je automatické. Po prvej iterácii sa testuje podmienka. Ak je <em>true,</em> tak sa opäť vykoná cyklus. Ak <em>false</em>, tak cyklus skončil a&nbsp;pokračuje sa ďalej v&nbsp;programe.</p>
<p>﻿<strong>2. príklad: </strong>&nbsp;Vykoná sa aspoň jedná iterácia? ﻿</p>
<pre>#include &lt;iostream&gt;
 using namespace std;
 
 int main()
 {
 &nbsp; int cislo = 0;
 
 &nbsp; do&nbsp;{
 &nbsp;&nbsp;&nbsp; cout &lt;&lt; "Ja som cislo: " &lt;&lt; cislo &lt;&lt; "\n";
 &nbsp;&nbsp;&nbsp; cislo++;
 &nbsp; } while (cislo &lt; 1);
 
 &nbsp; return 0;
 }﻿</pre>
<p>Výsledok programu: ﻿</p>
<pre class="Pedformtovantext">Ja som cislo: 0</pre>
<p class="Pedformtovantext"><em>Rozbor programu: </em>Ako vidíte, jedná iterácia sa vykonala. O&nbsp;tom je cyklus <em>do while</em>.﻿</p>
<p><strong>3. príklad: </strong>﻿﻿</p>
<pre>#include &lt;iostream&gt;
 using namespace std;
 
 int main()
 {
 &nbsp; int cislo = 0;
 &nbsp; bool isTrue = false;

&nbsp; do&nbsp;{
 &nbsp;&nbsp;&nbsp; cislo++;
 &nbsp;&nbsp;&nbsp; cout &lt;&lt; "Ja som cislo: " &lt;&lt; cislo &lt;&lt; "\n";
 
 &nbsp;&nbsp;&nbsp; if (cislo == 10)
 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; isTrue = true;&nbsp;&nbsp;&nbsp; // zmena pravdivostnej hodnoty
 &nbsp; } while (!isTrue);
 
 &nbsp; return 0;
 }﻿</pre>
<p>Výsledok programu: ﻿</p>
<pre>Ja som cislo: 1
 Ja som cislo: 2
 Ja som cislo: 3
 Ja som cislo: 4
 Ja som cislo: 5
 Ja som cislo: 6
 Ja som cislo: 7
 Ja som cislo: 8
 Ja som cislo: 9
 Ja som cislo: 10﻿</pre>
<p><em>Rozbor programu: </em>﻿</p>
<p>V&nbsp;podmienke <em>while </em>máme pravdivostnú premennú, ktorou určíme fungovanie cyklu. Ak je premenná <em>isTrue</em> false, tak cyklus prebehne ešte raz. Ak je true, tak cyklus skončí. Pre tých, ktorí nevedia skrátený zápis podmienky, tak <em>!</em><em>isTrue</em> je to isté, ako <em>isTrue </em><em>== false</em>.﻿</p>
<p><strong>4. príklad: </strong>Vyhláskujem ti tvoje meno﻿</p>
<pre class="Pedformtovantext">#include &lt;iostream&gt;
using namespace std;
int main()
{
&nbsp; string name;
&nbsp; cout &lt;&lt; "Napis svoje meno: ";
&nbsp; cin &gt;&gt; name;
&nbsp; if (name.empty())
&nbsp; {
&nbsp;&nbsp;&nbsp; cout &lt;&lt; "Sorry, ale nieco musis napisat. Skus to este raz!";
&nbsp;&nbsp;&nbsp; return 0;
&nbsp; }
&nbsp; size_t i&nbsp;= 0;
&nbsp; do&nbsp;{
&nbsp;&nbsp;&nbsp; cout &lt;&lt; name[i] &lt;&lt; " ";
&nbsp;&nbsp;&nbsp; i++;
&nbsp; } while (i &lt; name.size());
&nbsp; return 0;
}</pre>
<p>Výsledok programu:</p>
<pre>Napis svoje meno: eduard
 e d u&nbsp;a&nbsp;r d﻿</pre>
<p><em>Rozbor programu: </em>Najprv vstup od&nbsp;užívateľa. Následne prebieha cyklus <em>do while</em> až pokým premenná <em>i </em>je rovná veľkostí reťazca (ukončovací znak sa do&nbsp;veľkostí reťazca neberie do&nbsp;úvahy).﻿</p>
<p>Na&nbsp;koniec použijeme príklad z&nbsp;minulého <a class="new-window" href="/software/programovanie-v-jazyku-c-cyklus-while-1" onclick="return !bar(this.href);" title="[Odkaz do nového okna] ">dielu</a>. Zmeníme ho na&nbsp;<em>do while </em>cyklus. Myslíte, že bude výrazná zmena?</p>
<p><strong>5. príklad: </strong>Tvoje meno v&nbsp;ASCII kóde﻿</p>
<pre>#include &lt;iostream&gt;
 using namespace std;
 
 int main()
 {
 &nbsp;&nbsp;&nbsp;&nbsp; string name;
 
 &nbsp;&nbsp;&nbsp;&nbsp; cout &lt;&lt; "Napis svoje obcianske meno!\n";
 &nbsp;&nbsp;&nbsp;&nbsp; cin &gt;&gt; name;
 
 &nbsp;&nbsp;&nbsp;&nbsp; if (name.empty())
 &nbsp;&nbsp;&nbsp;&nbsp; {
 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; cout &lt;&lt; "Ale daco musis napisat no, nestvi ma!";
 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; return 0;
 &nbsp;&nbsp;&nbsp;&nbsp; }
 
 &nbsp;&nbsp;&nbsp;&nbsp; size_t i&nbsp;= 0;
 
 &nbsp;&nbsp; &nbsp;&nbsp;do {
 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; cout &lt;&lt; name[i] &lt;&lt; ": " &lt;&lt; static_cast&lt;int&gt;(name[i]) &lt;&lt; "\n";
 &nbsp;&nbsp;&nbsp; // tu pretypujeme a&nbsp;vypíšeme na&nbsp;obrazovku
 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; i++;
 &nbsp;&nbsp;&nbsp;&nbsp; } while (i &lt; name.size());
 
 &nbsp;&nbsp;&nbsp;&nbsp; return 0;
 &nbsp;}﻿
</pre>
<p>Výsledok programu: ﻿</p>
<pre>Napis svoje obcianske meno!
 eduard
 e: 101
 d: 100
 u: 117
 a: 97
 r: 114
 d: 100﻿</pre>
<p><em>Rozbor programu: </em>﻿</p>
<p>Všetko funguje ako má.</p>
</div>
<div class="article_chapter">
<div class="top">
<a href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-cyklus-while-1" title="Programovanie v jazyku C++: Cyklus while (1)" class="prev">Předchozí kapitola</a>
<a href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-uvod-a-historia-1" title="Programovanie  v jazyku C++: Úvod a história (1)" class="center" >Zpět na obsah</a>
</div>
</div>
<div class="art-banner">
<!-- le_article_bottom_468x60 -->
<div align="center"><!-- id=2845 --><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- LE-468x60 -->
<ins class="adsbygoogle"
style="display:inline-block;width:468px;height:60px"
data-ad-client="ca-pub-2826757030954706"
data-ad-slot="5121894444"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
<div id="social-links">
<div class="social-btns">
<a href="//twitter.com/share" class="twitter-share-button" data-text="Programovanie v jazyku C++: Cyklus while (2)" data-count="horizontal" data-via="LinuxEXPRES" data-related="liberix:Podporujeme svobodný software.">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
<a class="FlattrButton" style="display:none;"
title="Programovanie v jazyku C++: Cyklus while (2)"
data-flattr-uid="liberix"
data-flattr-button="compact"
data-flattr-title="Programovanie v jazyku C++: Cyklus while (2)"
data-flattr-language="cs_CZ"
data-flattr-description=" Druhý diel sa zapodieva cyklom do&amp;nbsp;while. Dočítate sa o&amp;nbsp;funkcionalite spomenutého cyklu a&amp;nbsp;naučíte sa s&amp;nbsp;ním pracovať na&amp;nbsp;základe ukážkových príkladov. "
data-flattr-tags="open source, Linux, FOSS, Liberix"
data-flattr-category="text"
href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-cyklus-while-2">
</a>
<a class="delicious" id="social_delicious" href="http://del.icio.us/post?url=https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-cyklus-while-2&amp;title=Programovanie%20v%20jazyku%20C%2B%2B%3A%20Cyklus%20while%20%282%29" onclick="return !bar(this.href)">del.icio.us<span>&nbsp;</span></a>
<div class="g-plusone"></div>
<script type="text/javascript">
            (function() {
              var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
              po.src = '//apis.google.com/js/plusone.js';
              var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);            })();
          </script>
</div>
<p id="fb_like"></p>
<script type="text/javascript">
          // <![CDATA[
          if (twttr && twttr.events) {
            twttr.events.bind('tweet', function() {
            ga('send', 'social', {socialNetwork: 'Twitter', socialAction: 'tweet', window.location.href});
            });
          }
          $('social_pridej').observe('click', function(){
          ga('send', 'social', {socialNetwork: 'Pridej.cz', socialAction: 'share', window.location.href});
          });
          $('social_delicious').observe('click', function(){
           ga('send', 'social', {socialNetwork: 'Delicious', socialAction: 'share', window.location.href});
          });
          $('fb_like').update('<fb:like href="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-cyklus-while-2" show_faces="true" action="like"></fb:like>');
          // ]]>
        </script>
<span class="cleaner"></span>
</div>
<p class="top">
<a data-role="button" data-inline="true" data-theme="a" href="#article">Nahoru</a>
</p>
</div>
<!-- google_ad_section_end -->
<!--Sklik-kontext-stop -->
</article>
<div class="rating">
<form action="https://www.linuxexpres.cz/modules/rateit/rate.php" method="post">
<div class="rateit-form">
<input type="hidden" name="element_id" value="7183" />
<input type="hidden" name="element_type" value="1" />
<input type="hidden" name="mid" value="10" />
<input type="hidden" name="return_url" value="http://www.linuxexpres.cz:80/software/programovanie-v-jazyku-c-cyklus-while-2" />
<input type="radio" name="vote" value="1" id="rate-1" title="Výborný" /><label class="rate_text" for="rate-1" title="Výborný" >1</label>
<input type="radio" name="vote" value="2" id="rate-2" title="Chvalitebný" /><label class="rate_text" for="rate-2" title="Chvalitebný" >2</label>
<input type="radio" name="vote" value="3" id="rate-3" title="Průměrný" /><label class="rate_text" for="rate-3" title="Průměrný" >3</label>
<input type="radio" name="vote" value="4" id="rate-4" title="Podprůměrný" /><label class="rate_text" for="rate-4" title="Podprůměrný" >4</label>
<input type="radio" name="vote" value="5" id="rate-5" title="Špatný" /><label class="rate_text" for="rate-5" title="Špatný" >5</label>
<span class="rateit-info">(Jako ve škole)</span>
<input class="rateit-submit" type="submit" value="Ohodnoť!" title="Ohodnoť" />
</div>
</form>
<span class="rateit-outcome">
<span>Průměr: <strong>1,00</strong></span>&nbsp;|&nbsp;<span>Hodnotilo: <strong> 1</strong></span>
</span>
<script type="text/javascript">
ga('set', 'dimension4', '1,00'); 
   
</script>
<div class="cleaner">&nbsp;</div>
</div>                                          <h3 class="topartcles"><a href="http://www.openoffice.cz">Top články z OpenOffice.cz</a></h3><div id="stick-art" class="intro-articles"><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="https://www.openoffice.cz/uploads/perex/LO_Writer.png"> </div><h3><a title="Vytvoření PDF formuláře pomocí Writeru" href="https://www.openoffice.cz/navody/vytvoreni-pdf-formulare-pomoci-writeru?source=rss">Vytvoření PDF formuláře pomocí Writeru</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="https://www.openoffice.cz/uploads/perex/doplnek.png"> </div><h3><a title="Překlad textu v dokumentu, formátování stránek a vyplnění prázdných buněk" href="https://www.openoffice.cz/navody/preklad-textu-v-dokumentu-formatovani-stranek-a-vyplneni?source=rss">Překlad textu v dokumentu, formátování stránek a vyplnění prázdných buněk</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="https://www.openoffice.cz/uploads/perex/doplnek.png"> </div><h3><a title="Odstraňování duplicit, export obrázků a přímé míchání barev" href="https://www.openoffice.cz/navody/odstranovani-duplicit-export-obrazku-a-prime-michani-barev?source=rss">Odstraňování duplicit, export obrázků a přímé míchání barev</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="https://www.openoffice.cz/uploads/perex/masterpdfeditor_logo.png"> </div><h3><a title="Master PDF Editor: „Adobe Acrobat“ pro Linux (1)" href="https://www.openoffice.cz/recenze/master-pdf-editor-adobe-acrobat-pro-linux-1?source=rss">Master PDF Editor: „Adobe Acrobat“ pro Linux (1)</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="https://www.openoffice.cz/uploads/perex/LO.png"> </div><h3><a title="LibreOffice Online: co je nového v srpnu 2016?" href="https://www.openoffice.cz/recenze/libreoffice-online-co-je-noveho-v-srpnu-2016?source=rss">LibreOffice Online: co je nového v srpnu 2016?</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="//www.openoffice.cz/uploads/perex/LO5_1.png"> </div><h3><a title="LibreOffice 5.2: změny v programových modulech" href="https://www.openoffice.cz/recenze/libreoffice-5-2-zmeny-v-programovych-modulech?source=rss">LibreOffice 5.2: změny v programových modulech</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="//www.openoffice.cz/uploads/perex/Libreoffice_icon_mix48b.png"> </div><h3><a title="LibreOffice 5–6/2016: nový český slovník synonym, funkce Excelu v Calcu a Případy 1. oddělení" href="https://www.openoffice.cz/recenze/libreoffice-5-6-2016-novy-cesky-slovnik-synonym-funkce?source=rss">LibreOffice 5–6/2016: nový český slovník synonym, funkce Excelu v Calcu a Případy 1. oddělení</a></h3><div class="cleaner"></div></div><div class="stick-art-item"><div class="stick-art-item-thumb"><img class="perex_image" src="//www.openoffice.cz/uploads/perex/LO.png"> </div><h3><a title="Cloudová řešení LibreOffice v červnu 2016" href="https://www.openoffice.cz/recenze/cloudova-reseni-libreoffice-v-cervnu-2016?source=rss">Cloudová řešení LibreOffice v červnu 2016</a></h3><div class="cleaner"></div></div></div>                                          <!-- LE26 -->  
<div id="heurekaIframeHeader" style="text-align: left; margin: 0 auto; font-weight: bold; padding-bottom: 2px;"><a href="http://mobilni-telefony.heureka.cz/#c4222:56" target="_blank">Top Mobilní telefony</a></div> <script type="text/javascript"> document.write('<iframe src=\"//www.heureka.cz/direct/bannery/?&cid=731:56:4222\" width=\"660\" height=\"170\" frameborder=\"0\" scrolling=\"no\"><\/iframe>'); </script>                                                                                                                                                                                                    <div class="inform">
<h3><a id="form"></a>Přidat téma diskuse</h3>
<p>
Nejsou podporovány žádné značky, komentáře jsou jen čistě textové.
<strong>Více o diskuzích a pravidlech najdete <a href="http://www.linuxexpres.cz/o-webu/diskuze-ke-clanku">v nápovědě</a></strong>. <br />
Diskuzi můžete sledovat pomocí
<a href="https://www.linuxexpres.cz/rss/diskuze/0">
RSS kanálu</a>
<a href="https://www.linuxexpres.cz/rss/diskuze/0">
<img src="/themes/le/images/rss.gif" alt="rss" /></a>
</p>
<form action="https://www.linuxexpres.cz/modules/forum/forum.php" method="post" class="discuss-form">
<div class="l-part">
<label class="ui-hidden-accessible" for="user_name">Vaše jméno:</label>
<input type="text" name="user_name" placeholder="Vaše jméno" id="user_name" size="60" value="" /><br />
<label class="ui-hidden-accessible" for="psubject">Předmět:</label>
<input type="text" name="psubject" placeholder="Předmět" id="psubject" size="60" value="Programovanie v jazyku C++: Cyklus while (2)" />
<br />
<label class="ui-hidden-accessible" for="check">Hlavní město ČR:</label>
<input type="text" name="check" placeholder="Hlavní město ČR" id="check" size="60" value="" />  </div>
<div class="r-part">
<label>Váš příspěvek:</label>
<textarea class="b" name="pbody" id="pbody" rows="20" cols="45"></textarea>
</div>
<div class="cleaner">&nbsp;</div>
<input type="hidden" value="0" name="id_topic" />
<input type="hidden" value="1" name="id_forum" />
<input type="hidden" value="" name="id_parent" />
<input type="hidden" value="7183" name="id_object" />
<input type="hidden" value="article" name="object_name" />
<input type="hidden" value="marwel" name="action" />
<input type="hidden" value="https://www.linuxexpres.cz/software/programovanie-v-jazyku-c-cyklus-while-2" name="location" />
<input data-theme="a" type="submit" class="submit" value="Odeslat" name="submit" />
<div class="cleaner">&nbsp;</div>
</div>
</form>
<!--
-->                                                                    </div>
</div>
</div>
<div class="right">
<div class="column-in">
<div id="b-68" class="rb">
<div>
<div class="authorinfo">
<p class="img">
<a href="https://www.linuxexpres.cz/userinfo.php?uid=5967"
><img src="https://www.linuxexpres.cz/uploads/cavt585c6dadb1b9f.jpg" alt="Eduard Boldižár" /></a>
</p>  
<h4>Eduard Boldižár</h4>
<p>
Som redaktorom stránky Exospace.cz. Mám 23 rokov. Čas trávim v IT škole. Medzi moje záľuby patrí astronómia, sci-fi literatúra a programovanie.
</p>
<hr class="cleaner" />
<ul>
<li>Distribuce: ubuntu</li>              <li>Grafické prostředí:
unity
</li>
<li>Hodnocení autora: <strong><a href="/o-webu/redakce#hodnoceni"><img src="https://www.linuxexpres.cz/themes/le/images/hodnoceni-1.png" alt="*" title="REGULAR" /></a></strong></li>
</ul>
<p class="r">
<a rel="author" href="https://www.linuxexpres.cz/modules/profile/userinfo.php?uid=5967">profil autora</a>  
</p>
<hr class="cleaner" />
</div>
</div>
</div>
<div id="b-77" class="rb hslice">
<h2 class="entry-title" style="display:none">Zaměstnání</h2>
<div class="entry-content">
<div id="jobs_block">
<div class="jobs_header">
<a class="jobs-logo" title="Jobs.cz - aktuální nabídka práce" target="_parent" href="http://www.jobs.cz/">
<img src="https://www.linuxexpres.cz/modules/jobscz/images/jobs.png" title="Jobs.cz - aktuální nabídka práce" alt="Jobs.cz - spojení s elitou - nabídka práce" />
</a>
<a class="jobs-title" href="http://www.jobs.cz" title="Jobs.cz - aktuální nabídka práce nejen v informačních technologiích">Práce v IT</a></h3>
<div class="cleaner"></div>  
</div>
<ul>
<li class="even">
<a href="https://www.linuxexpres.cz/modules/jobscz/counter.php?url=http%3A%2F%2Fwww.jobs.cz%2Fpd%2F1167617714%2F%3Frps%3D74">
PLC programátor
</a>
</li>
<li class="odd">
<a href="https://www.linuxexpres.cz/modules/jobscz/counter.php?url=http%3A%2F%2Fwww.jobs.cz%2Fpd%2F1180483665%2F%3Frps%3D74">
BI Developer Junior
</a>
</li>
<li class="even">
<a href="https://www.linuxexpres.cz/modules/jobscz/counter.php?url=http%3A%2F%2Fwww.jobs.cz%2Fpd%2F1164944351%2F%3Frps%3D74">
konzultant
</a>
</li>
<li class="odd">
<a href="https://www.linuxexpres.cz/modules/jobscz/counter.php?url=http%3A%2F%2Fwww.jobs.cz%2Fpd%2F1126520848%2F%3Frps%3D74">
SysAdmin/DevOps (Linux) s otevřenou hlavou
</a>
</li>
<li class="even">
<a href="https://www.linuxexpres.cz/modules/jobscz/counter.php?url=http%3A%2F%2Fwww.jobs.cz%2Fpd%2F1164549716%2F%3Frps%3D74">
PHP vývojář s vášní pro Nette/Symfony (Brno)
</a>
</li>
<li class="odd">
<a href="https://www.linuxexpres.cz/modules/jobscz/counter.php?url=http%3A%2F%2Fwww.jobs.cz%2Fpd%2F1180951786%2F%3Frps%3D74">
Tester
</a>
</li>
</ul>
<p class="r"><a href="http://it.jobs.cz" title="Zborazit další nabídky práce na serveru Jobs.cz nejen z IT">více nabídek práce &raquo;</a></p>
<div class="jobs_footer"><span>Tip:</span> <a href="http://www.jobs.cz/kurzy-a-skoleni/" title="Školení, kurzy, semináře a rekvalifikace přehledně na Jobs.cz">Kurzy, školení a semináře</a> »</div>
</div>
</div>
</div>
<div id="blogs">
<div id="b-194" class="rb">
<div>
<div align="center"><!-- id=3947 --><A HREF="https://ad.doubleclick.net/ddm/jump/N410401.2103509SYSTEMONLINE/B10790889.145769795;sz=300x250;ord=[timestamp]?">
<IMG SRC="https://ad.doubleclick.net/ddm/ad/N410401.2103509SYSTEMONLINE/B10790889.145769795;sz=300x250;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER=0 WIDTH=300 HEIGHT=250 ALT="Advertisement"></A>
<!--
<A HREF="https://ad.doubleclick.net/ddm/jump/N7384.2103509SYSTEMONLINE/B8071081.133683190;sz=300x250;ord=[timestamp]?">
<IMG SRC="https://ad.doubleclick.net/ddm/ad/N7384.2103509SYSTEMONLINE/B8071081.133683190;sz=300x250;ord=[timestamp];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" BORDER=0 WIDTH=300 HEIGHT=250 ALT="Advertisement"></A>
--></div>
</div>
</div>
<div id="b-208" class="rb">
<div>
<h2 class="sol"><a href="https://www.systemonline.cz">SystemOnLine.cz</a></h2>
<div class="rssbox"><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="http://www.systemonline.cz/zpravy/ddos-utoky-jsou-opet-na-vzestupu-z.htm"><img class="rssbox-image" src="//www.ccb.cz/images_aqua/2017/unor/ddos1706.jpg"/></a>
</div>
<a href="http://www.systemonline.cz/zpravy/ddos-utoky-jsou-opet-na-vzestupu-z.htm">DDoS útoky jsou opět na vzestupu</a>
<div class="cleaner"></div>
</div><div class="cleaner"></div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="http://www.systemonline.cz/clanky/digitalizace-v-rizeni-hr-prinasi-spokojene-zamestnance.htm"><img class="rssbox-image" src="//www.ccb.cz/images_aqua/2016/prosinec/12-sap-01z.jpg"/></a>
</div>
<a href="http://www.systemonline.cz/clanky/digitalizace-v-rizeni-hr-prinasi-spokojene-zamestnance.htm">Digitalizace v řízení HR přináší spokojené zaměstnance</a>
<div class="cleaner"></div>
</div><div class="cleaner"></div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="http://www.systemonline.cz/clanky/vzdelavanim-ke-kyberneticke-bezpecnosti.htm"><img class="rssbox-image" src="//www.ccb.cz/images_aqua/2016/prosinec/12-alef-01z.jpg"/></a>
</div>
<a href="http://www.systemonline.cz/clanky/vzdelavanim-ke-kyberneticke-bezpecnosti.htm">Vzděláváním ke kybernetické bezpečnosti</a>
<div class="cleaner"></div>
</div><div class="cleaner"></div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="http://www.systemonline.cz/zpravy/komunikace-firem-stale-stoji-na-e-mailech-z.htm"><img class="rssbox-image" src="//www.ccb.cz/images_aqua/2017/unor/email_1706.png"/></a>
</div>
<a href="http://www.systemonline.cz/zpravy/komunikace-firem-stale-stoji-na-e-mailech-z.htm">Komunikace firem stále stojí na e-mailech</a>
<div class="cleaner"></div>
</div><div class="cleaner"></div>
</div>
</div>
<div id="b-209" class="rb">
<div>
<h2 class="sol"><a href="https://www.cad.cz">CAD.cz</a></h2>
<div class="rssbox"><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.cad.cz/aktuality/77-aktuality/7733-predprodej-vylepsene-3d-tiskarny-sigma-r17.html"><img class="rssbox-image" src="//www.cad.cz/images/stories/aktuality/2017/02/Sigma_Gillemmmm-1706.jpg"/></a>
</div>
<a href="https://www.cad.cz/aktuality/77-aktuality/7733-predprodej-vylepsene-3d-tiskarny-sigma-r17.html">Předprodej vylepšené 3D tiskárny Sigma R17</a>
<div class="cleaner"></div>
</div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.cad.cz/aktuality/77-aktuality/7732-nova-verze-archicad-connection-podporuje-revit-2017.html"><img class="rssbox-image" src="//www.cad.cz/images/stories/aktuality/2017/02/revit-mep_cr-1706.jpg"/></a>
</div>
<a href="https://www.cad.cz/aktuality/77-aktuality/7732-nova-verze-archicad-connection-podporuje-revit-2017.html">Nová verze ArchiCAD Connection podporuje Revit 2017</a>
<div class="cleaner"></div>
</div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.cad.cz/aktuality/77-aktuality/7731-dcs-vydava-3dcs-variation-analyst-pro-creo.html"><img class="rssbox-image" src="//www.cad.cz/images/stories/aktuality/2017/02/dcs-Mouse_MoveSeparated2-1706w.png"/></a>
</div>
<a href="https://www.cad.cz/aktuality/77-aktuality/7731-dcs-vydava-3dcs-variation-analyst-pro-creo.html">DCS nabízí 3DCS Variation Analyst pro Creo</a>
<div class="cleaner"></div>
</div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.cad.cz/aktuality/77-aktuality/7730-stratasys-prichazi-s-3d-tiskarnami-f123-series.html"><img class="rssbox-image" src="//www.cad.cz/images/stories/aktuality/2017/02/stratasys-F123-1706.jpg"/></a>
</div>
<a href="https://www.cad.cz/aktuality/77-aktuality/7730-stratasys-prichazi-s-3d-tiskarnami-f123-series.html">Stratasys přichází s 3D tiskárnami F123 Series</a>
<div class="cleaner"></div>
</div></div><div class="cleaner"></div>
</div>
</div>
<div id="b-142" class="rb">
<div>
<h2>Redakční blog</h2>
<div class="article-content">
<div class="mw_field"><div class="bloglist">
<div class="item">
<div class="foto">
<img src="https://www.linuxexpres.cz/uploads/cavt4efc5f0e2831c.png"
alt="Pavel Fric" />
</div>
<div class="bcontent">
<p class="rinfo">
Pavel Fric, 28. únor
</p>
<h4><a href="https://www.linuxexpres.cz/blog/lollypop">Lollypop</a></h4>
<p class="bperex"></p>
</div>
<hr class="cleaner" />
</div>
<div class="item">
<div class="foto">
<img src="https://www.linuxexpres.cz/uploads/cavt4efc5f0e2831c.png"
alt="Pavel Fric" />
</div>
<div class="bcontent">
<p class="rinfo">
Pavel Fric, 29. listopad
</p>
<h4><a href="https://www.linuxexpres.cz/blog/palapeli-1">Palapeli</a></h4>
<p class="bperex"></p>
</div>
<hr class="cleaner" />
</div>
<div class="item">
<div class="foto">
<img src="https://www.linuxexpres.cz/uploads/cavt4efc5f0e2831c.png"
alt="Pavel Fric" />
</div>
<div class="bcontent">
<p class="rinfo">
Pavel Fric, 19. listopad
</p>
<h4><a href="https://www.linuxexpres.cz/blog/amarok-1">Amarok</a></h4>
<p class="bperex"></p>
</div>
<hr class="cleaner" />
</div>
</div></div>
<p class="r"><a href="https://www.linuxexpres.cz/blog" title="Blog">Všechny blogy »</a></p>
</div>
</div>
</div>
<div id="b-220" class="rb">
<div>
<h2 class="sol"><a href="http://www.OpenOffice.cz">OpenOffice.cz</a></h2>
<div class="rssbox oosidebar"><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.openoffice.cz/recenze/libreoffice-5-3-programove-moduly?source=rss"><img class="rssbox-image" src="https://www.openoffice.cz/uploads/perex/LO5_1.png"/></a>
</div>
<a href="https://www.openoffice.cz/recenze/libreoffice-5-3-programove-moduly?source=rss">LibreOffice 5.3 – programové moduly</a>
<div class="cleaner"></div>
</div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.openoffice.cz/navody/programovanie-makier-v-libreoffice-rekurzia?source=rss"><img class="rssbox-image" src="https://www.openoffice.cz/uploads/perex/LO.png"/></a>
</div>
<a href="https://www.openoffice.cz/navody/programovanie-makier-v-libreoffice-rekurzia?source=rss">Programovanie makier v LibreOffice: Rekurzia</a>
<div class="cleaner"></div>
</div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.openoffice.cz/novinky/je-tady-libreoffice-5-3?source=rss"><img class="rssbox-image" src="https://www.openoffice.cz/uploads/perex/novinky.png"/></a>
</div>
<a href="https://www.openoffice.cz/novinky/je-tady-libreoffice-5-3?source=rss">Je tady LibreOffice 5.3</a>
<div class="cleaner"></div>
</div><div class="rssbox-item">
<div class="rssbox-thumb">
<a href="https://www.openoffice.cz/novinky/libreoffice-5-2-5?source=rss"><img class="rssbox-image" src="https://www.openoffice.cz/uploads/perex/LO5_1.png"/></a>
</div>
<a href="https://www.openoffice.cz/novinky/libreoffice-5-2-5?source=rss">LibreOffice 5.2.5</a>
<div class="cleaner"></div>
</div></div><div class="cleaner"></div>
</div>
</div>
<div id="b-213" class="rb">
<div>
<div class="feed">
<h2>Forum OpenOffice.cz</h2>
<ul>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4340&action=new" target="_blank">Univerzální použití makra v různých formulářích</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4336&action=new" target="_blank">Samovolná změna vzorce - VYŘEŠENO</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4337&action=new" target="_blank">zdobné ohraničení stránky</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4338&action=new" target="_blank">Aktualizace dat z CSV souboru - VYŘEŠENO</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4339&action=new" target="_blank">Writer - nabídka uložit obrázek na pozadí...</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4327&action=new" target="_blank">Počítání znaků v Calcu nebo vyjmutí textu bez...</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4335&action=new" target="_blank">Jak omezit nabídku posledních dokumentů - VYŘEŠENO</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4334&action=new" target="_blank">Seskupení hodnot podle datumu - VYŘEŠENÝ</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4333&action=new" target="_blank">hromadná korespondence samostatná PDF - Vyřešeno</a></li>
<li><a href="https://forum.openoffice.cz/viewtopic.php?id=4331&action=new" target="_blank">Zobrazení dat z BASE v CALCu - VYŘEŠENÝ</a></li>
</ul>
<p><a href="https://forum.openoffice.cz/" target="_blank">Forum OpenOffice.cz »</a></p>
</div>
</div>
</div>
<div id="b-223" class="rb">
<div>
<br />
Tip: <a target="_blank" href="http://www.jawtemplates.com/wordpress-themes/gday-news-magazine/">Wordpress Magazine Theme</a>
</div>
</div>
</div>
<div id="b-196" class="rb">
<div>
<!-- LE30_pravy_sloupec_clanek_dole_250x60 -->
</div>
</div>
</div>
</div>
<div class="cleaner"></div>
</div>
<div class="cleaner"></div>
</div>
<div class="cleaner"></div>
</div>
<div id="search">
<form action="https://www.linuxexpres.cz/search.php" id="searchform" >
<div>
<input type="hidden" name="action" value="results" />
<label><input value="VYHLEDÁVÁNÍ" name="query" id="search-input" accesskey="4"
onfocus="searchClear(this,  'VYHLEDÁVÁNÍ');"
onblur="searchRestore(this, 'VYHLEDÁVÁNÍ');" /></label>
<label><input type="image" src="https://www.linuxexpres.cz/themes/le/images/search_btn.png" id="go_button" alt="OK" /></label>
</div>
</form>      </div>
<div id="banner-right">
</div>
<footer>
<div class="footer-top">
<!-- LE11 -->
</div>
<div class="footer-bottom">
<div class="article-content">
<div class="span6 first">
<p><br /><strong>LinuxEXPRES </strong>- opravdový linuxový magazín, ISSN 1801-3996<br />Copyright © 2017 CCB, spol. s r. o., všechna práva vyhrazena. <br /> Provozuje <a href="http://www.ccb.cz/kontakty.html" title="Vydavatelství CCB, spol. s r. o."><strong>CCB, spol. s r. o.</strong></a><strong></strong></p>
<p><a href="/kontakty">Kontakt</a> | <a href="/o-webu/reklama">Inzerce</a> | <a href="/o-webu">O webu</a> | <a href="/o-webu/rss">RSS</a> | <a href="http://www.facebook.com/Linuxexpres">Facebook</a> | <a href="http://twitter.com/LinuxEXPRES">Twitter</a> | <a href="https://plus.google.com/115061994921030198037/posts">Google+</a> | <a href="http://m.linuxexpres.cz">Mobilní verze</a>﻿</p>
</div>
<div class="span6 sec">
<p>Partnerské weby CCB:<br /> <a href="http://www.systemonline.cz"><strong>SystemOnLine.cz</strong></a>: Informační systémy, ERP, CRM, řízení výroby, správa dokumentů, IT bezpečnost.<br /><a href="http://www.cad.cz"><strong>CAD.cz</strong></a>: Novinky a články ze světa CAD, CAM, PLM a GIS.<br /> <a href="http://www.ERPforum.cz"><strong>ERPforum.cz</strong></a>: specializovaný portál o ERP systémech.<br /> <a href="http://www.OpenOffice.cz"><strong>OpenOffice.cz</strong></a>: portál uživatelů OpenOffice a LibreOffice.</p>
</div>
<div class="cleaner">&amp;nbps;</div>
</div>
</div>
<div class="partners">
<span>Doporučujeme:</span>  <a href="http://www.openoffice.cz/">OpenOffice.cz</a> | <a  href="http://www.mandrivalinux.cz/">Mandriva Linux</a>
</div>        
</footer>
</div>
<script type="text/javascript">
        //SyntaxHighlighter.config.stripBrs = true;
        SyntaxHighlighter.all();
      </script>
</div>
<!-- Begin Cookie Consent plugin by Silktide - http://silktide.com/cookieconsent -->
<script type="text/javascript">
    window.cookieconsent_options = {"message":"Vážený návštěvníku, tato stránka používá soubory cookies. Prohlížením tohoto webu souhlasíte s využíváním těchto souborů.","dismiss":"Souhlasím","learnMore":"Více informací","link":null,"theme":"light-bottom"};
</script>
<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>
<!-- End Cookie Consent plugin -->   
<script type="text/javascript">
 ga('require', 'displayfeatures');  
  ga('send', 'pageview');
</script>
</body>
</html>
<!-- qcmmon state ok -->